visualdatatools.com Forum Index visualdatatools.com
Discussion for DataTank and DataGraph
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Adding Datagraph Framework in Xcode 4

 
Post new topic   Reply to topic    visualdatatools.com Forum Index -> DataGraph Framework
View previous topic :: View next topic  
Author Message
klaxamazoo



Joined: 17 Jul 2009
Posts: 47
Location: Artic

PostPosted: Thu Mar 24, 2011 8:47 pm    Post subject: Adding Datagraph Framework in Xcode 4 Reply with quote

I'm writing a simple application to analyze my data and I wanted to ad some graphing capabilities. However, I'm having trouble adding the Datagraph framework to my projects in Xcode 4. I keep getting the following error.

Code:

This GDB was configured as "x86_64-apple-darwin".tty /dev/ttys000
warning: Unable to read symbols for @executable_path/../Frameworks/DataGraph.framework/Versions/A/DataGraph (file not found).
warning: Unable to read symbols from "DataGraph" (not yet mapped into memory).
dyld: Library not loaded: @executable_path/../Frameworks/DataGraph.framework/Versions/A/DataGraph
  Referenced from: /Users/OwenHildreth/Library/Developer/Xcode/DerivedData/DatagraphTest-gtffxglpdkbxwofnzavbtwappjrp/Build/Products/Debug/DatagraphTest.app/Contents/MacOS/DatagraphTest
  Reason: image not found
[Switching to process 4071 thread 0x0]
sharedlibrary apply-load-rules all
kill
quit
Program ended with exit code: 0


Do you have any suggestions for using the datagraph framework in Xcode 4?

Thanks
Back to top
View user's profile Send private message
Joe Brain



Joined: 18 Apr 2007
Posts: 120

PostPosted: Thu Apr 07, 2011 4:17 pm    Post subject: Reply with quote

I've upgraded my existing XCode project from 3 to 4 & everything still seems to be working.

I'm not sure if you have to do this, but I have a Build Phase (Copy Files) that copies the DataGraph.framework to the app's Frameworks directory.
Back to top
View user's profile Send private message
roktengr



Joined: 31 Dec 2010
Posts: 1

PostPosted: Wed Jun 06, 2012 12:22 pm    Post subject: Reply with quote

I just started a new program to use the framework for the first time, and I am also in Xcode 4. I tried compiling the "Basic" project in it, and it had the an error (see below). I compiled it in Xcode 3 on another machine, and it worked fine.

Any insights here? I downloaded the latest framework for April 2012.

Thanks much.

Edit: The error given is: "The scheme "Basic" contains no buildables that can be built for the SDK supported by the run destination My Mac 64-bit. Make sure your targets all specify SDKs that are supported by this version of Xcode."

The Xcode 3 machine was also 64 bit, so I do not think that is the issue.
Back to top
View user's profile Send private message
David
Site Admin


Joined: 25 Nov 2006
Posts: 1964
Location: Chapel Hill, NC

PostPosted: Sat Jun 09, 2012 1:14 pm    Post subject: Reply with quote

Download the framework again. There was an issue where the framework wanted to use the 10.5 framework, but that is not included in XCode 4. I changed the framework to be the most recent version (10.7). I tested it on XCode 4 and 10.7.

David
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    visualdatatools.com Forum Index -> DataGraph Framework All times are GMT - 3 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group