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Introduction 
The formatting approach in DataGraph may be different than what you are used to from other 
programs, but is well worth the effort to learn, as you can save lots of time and effort, while 
creating beautiful custom graphics.


The goal with DataGraph is to eliminate the tedious nature of creating graphs and 
understanding data.  When users out grow spreadsheets, they might feel the need to learn a 
programming language. In many ways, DataGraph is an intermediate approach.  You can think 
of DataGraph as a visual programming language.


Here we explain some fundamental aspect to DataGraph to get you started with the program, 
but there is much to the program beyond what we explain here.  One of the best ways to learn 
is to spend some time exploring the menus and trying them out. As you explore, hover over 
menus and entry boxes to learn more about what they do via a pop-up tool tip. 
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Terminology 
Objects – A rectangle that is used to represent a single data column, variable, layout setting, or drawing 
command.  


Icon – An image used to indicate the type of object that is located on the left side of the object. Many 
drawing  commands icons are dynamic, custom icons, meaning that the image changes to reflect 
formatting options.  


Data Column – The vertical organizational unit of data.  Click a column header to select the column.


Data Row –  The horizontal organizational unit of data the spans across columns.  Click on any entry to 
select a row, or record.


Row index – The numerical order of the data that is automatically assigned to each data row, or record.  
The index is the only column object in any new file and remains at the top of the column list.


Column List – The collective list of column objects contained in the data definition panel on the left of 
the user interface.  This list can be toggled from view by selecting View > Show/Hide Definitions (⌘–D).


Groups – The method used to organize columns, variables, command, and graphs.  Groups can be 
nested to have multiple levels, or a hierarchical data structure.


Data Table – The interface for interacting with data columns and data groups. Each data column and 
data group has a check box to show/hide contents from the data table.


Global variable – A single value (number, text, date, expression) that is listed in the section below the 
column list, separated by a sliding bar. 


Layout settings – Formatting options that are grouped into three sections: Style settings, Canvas 
settings, and Axis settings.  These three objects are pinned to the top of the object list above the graph.


Drawing command – The method used to draw elements to a graph including plotting, annotating, 
curve fitting, and drawing functions. The full list of commands is under the Command menu.


Thumbnail – A small image that represents each graph in a file that is used to toggle between them.


Clone – Make an identical copy.  For data columns, variables, commands, groups, use standard macOS 
option-drag to clone.  To clone an entire graph, select File > New Graph > Clone Current Graph.


Gear menu – The small gear shaped image that is located on every column, variable, command, 
thumbnail and group object.  Clicking the gear menu to reveal useful actions and shortcuts.


Mask – A logical statement that is used to specify that data to include in a drawing command.


Shared Mask – A logical statement that is used to specify that data for a group of commands.


Control-click – An action where you single click while holding down the control key.  The same action 
can be achieved by a two finger click on a touch pad, or a right click on a mouse. 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Getting Data 
One of the fastest ways to get data into DataGraph is via copy and paste. You can copy data 
from a text file or a spreadsheet. To paste, select Edit > Paste (⌘-V) or control-click on the 
data table and click Paste. DataGraph will analyze the data to determine the number of 
columns/rows, the data type for each column, and the presence of column titles.


After pasting, imported columns are highlighted in the data table. Click away from the data 
table to deselect. Every column has a corresponding object in the column list. An icon 
indicates the assigned data type on the left of the column object (numbers, text, or dates). If a 
header row is detected, the column objects will have a name; otherwise, you can type a 
column name manually. 


A built-in row counter indicates the number of rows on the left side of the data table. The row 
number is the first object in the column list and has the name ‘#’ by default. In a new file, the 
pasted data will start at row one. If you paste more data to the same rows, you can select any 
row below the data, but the data type and column names will not change.


Suppose a column is assigned the wrong data type (e.g., numbers assigned text), click the 
gear menu on the column object, and select Convert to … as needed. Changing the data type 
does NOT alter the underlying data. If the header was not in row one, hover your mouse over 
the row that contains the headers: Control-click and select ‘Use row to assign column titles’.


DATA GROUPS: Notice how when you click a record the entire row is highlighted. If columns 
are unrelated, you can organize them into data groups. To add columns to a group, click in the 
white space to the right of the columns, then drag to highlight the column objects you want to 
place in the group. Select Edit > Group (Control-⌘-G). This action creates a group object with 
the columns nested in the group. Click the check box on the group to toggle from view.


FILE TYPES: Import a data from a file using Data > Import File. You can also open CSV and 
MS Excel files directly. Contol-click on a file in the finder, and select ‘Open 
with DataGraph.’ That creates a new DataGraph file containing the data.


• CSV Files: CSV stands for comma separated values. These files 
usually import easily given the structured format of the data.  


• MS Excel Files: DataGraph imports columns that contain data. If 
the data span multiple tabs, DataGraph imports each tab into a 
data group. Cells with formulas are imported as numbers. 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Lesson 1 – Import with Copy & Paste 
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DataGraph vs. the Spreadsheet 

Unlike a spreadsheet where columns are named A, B, C. etc. DataGraph 
allows you to specify the name of every column in your data table.  You can 
double click on the names to edit or use the column list on the left of the 
interface to edit. 

When you paste the data, DataGraph checks the first row for column titles. Here you 
can see how the first row was used for the column header and first row of numbers, 
becomes the first row in the data table.

Copy and Paste is a quick way to 
import data into a DataGraph file. 


Consider the following example 
where three columns of numbers are 
a spreadsheet. 


To copy, click a corner of the data 
and drag to highlight, Next, select 
Edit > Copy (⌘-C).  



Visualizing Data  
Many graphing programs have drawing modes that create particular graph types. The 
DataGraph approach is different. DataGraph contains 20+ drawing commands that add 
elements to a graph. Commands can be combined to give you a lot of control and flexibility 
over the resulting visualization. Add Plots, Bars, Lines, Legends, Labels, Histograms, etc.


To add a command, select Command > Add … or click an icon in the toolbar. Note that the 
toolbar has several command shortcuts, but the complete list is under the Command menu. 
When you add a command, an object is added just above the graph. This object contains all 
the options for that command. The icon on the left side represents the type of command.


The main options are visible on the command. These include sliders, color menus, and data 
menus. Often the main options will be all you need to customize your graph. To reveal more 
options, click the top left corner of the command. Then you have more options for customizing 
the type of graph, adding labels, and editing legend entries.


Input data is selected using data menus. Click a data menu to select or edit the data input. 
When columns are nested in groups, you must scroll to the group to choose from its contents. 
Hover over a menu item, and a green arrow points to the corresponding entry in the column 
list. Many commands will not draw anything until the input has been selected.


For some commands, you can pre-select the data to populate the input data menus 
automatically. For example, the menus will be populated automatically for the Plot, Points and 
Fit commands when you have two number columns selected before you add the command(s).


HIDE & EXCLUDE: Each command is a drawing layer. Click and drag the command up and 
down to change the drawing order. Commands have 'Hide' and 'Exclude' check boxes on the 
right side. The Hide button hides the element from view. The Exclude button ignores the 
command completely and may result in the axis range changing. 


A NOTE ABOUT MASKS: If you have used spreadsheets for graphing, you may be tempted to 
select a subset of data by dragging across cells or rows; however, DataGraph has a more 
robust, data-driven approach to defining a subset – called a mask. The mask is a logical 
statement used to filter the rows of input data.


To add a mask, expand a command to locate the 'Use as Mask' option, typically in the middle 
of the command. Here, you can select any column in the data table as a basis for the mask 
(number, text, or date). Next, select the logic operator. Last, enter criteria for comparison.
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Lesson 2 – Add Commands 
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Add elements to your graph using 
commands.  Click the Command menu for 
the full list.  Each command is a distinct visual 
object above your graph.

Here you see one Plot command and one Label command.  The Plot command draws a line 
using the X Y data, in the columns ‘time’ and ‘airmiles.’  The Label command has a text box 
where a label can be typed directly.  You can type the label location or click and drag on the 
graph to point out locations on the line.

Click the top left corner of a command 
to reveal additional options.  You can 
add a mask to filter the data, add labels 
for each point, and change the legend 
entry. 



Formating a Graph 
The drawing commands control the content in a graph, while the Layout settings control the 
design, similar to a style sheet. In many graphing programs, graphic design is combined with 
the presentation of the data. By separating the content and the design, format options can be 
propagated across multiple graphs, saving you considerable time and effort by not having to 
repeat steps over and over again.


DataGraph also uses the concept of ‘cascading’ formatting, meaning that an overall setting 
applies to all elements in a graph. Still, you can specify different formatting options for 
individual elements, giving you complete control over your graphic.


That said, considerable effort has gone into DataGraphs default settings, so you get a nice, 
clean-looking graphic without having to spend a lot of effort. Many options are set to 
‘automatic’ or ‘nice’ and vary dynamically to produce a nice-looking graph as you change other 
settings (e.g., font size).  


In DataGraph, the Layout settings contain the formatting options and are divided amount the 
following three objects:

• Style settings, control font, color pallets, gridlines

• Canvas settings, control background colors, margins

• Axis settings, control tick mark locations, and axis labels.


FONTS: The top line of the Style settings controls the main font. Use the main font to change 
the font style, size, and color, for all text elements at once. Expanding the settings reveals 
several customizable font groups (e.g., axis labels, axis titles, data labels). Expand individual 
commands to change the font group or specify custom settings.


COLORS: The Style settings also control the colors. Click the color tiles to change the default 
font color and line color. Expanding the settings reveals the color tiles for the color menu. In 
individual commands, you can choose from the color menu or select the color picker to 
customize independently from the color menu. 


GRAPH SIZE: The Canvas settings have options for changing the size of the graph. By default, 
the size of the graph varies depending on the draggable edges or sliders. To set the size, 
change the size menu from ‘Automatic’ to ‘Specified’. A new entry box appears. Enter the 
width and height of the graph along with a unit of measure (in, cm, mm, px). If you do not 
include a unit of measure, it will be assumed to be a pixel.
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Lesson 3 – Use Layout Settings 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The Layout settings are the objects above 
the commands that control the font, color 
menu, graph size, axis titles, and more. 

The settings are organized in three sections: Style, Canvas, and Axis settings.  The settings 
are similar to a style sheet. Make changes to the format independent of the content drawn 
using the commands.  Use the menus to change the settings, sliders to change numerical 
values, click the color tiles to change the color settings.

Similar to the commands, expand the 
settings to reveal more options.  Here the 
Style settings show the font groups, tiles 
to edit the color menu, and many other 
formatting options. The formatting 
approach is cascading, as the changes 
here apply to all text for a group. 



Creating Multiple Graphs 
By default a DataGraph file contains one graph. A small version of the graph, or thumbnail is 
shown in the top left. To create a second graph, select File > New Graph > Standard Graph or 
use the ‘+’ symbol to the right of thumbnail.  This creates a standard graph, with no content.  
The style settings for the new graph will match the first graph.


Once you have two graphs, you can click the thumbnails to toggle between them. The 
thumbnail for the graph you are actively editing will have an outline, indicating it is selected. 
The selected graph is shown in the larger window (bottom right), and the corresponding layout 
settings and commands are shown above the graph.


Now that you have two graphs, you can independently change the format for either graph. 
When you add another new graph, the style settings will match the graph that had been 
selected. Thus, you can propagate the style settings as you make new graphs.


Another option is to make a complete copy or clone of a graph. To clone the active graph, 
select File > New Graph > Clone Current Graph.  This makes an identical copy that you can 
now edit without changing the original graph.


Transfer Settings Between Graphs: Select the layout setting you want to transfer (e.g., single 
click on the icon). To select multiple settings, click the white space just the right or below the 
settings, and drag to highlight.  With the settings highlighted, select Edit > Copy (⌘-C). Next, 
click the thumbnail of the graph where you want to apply the settings and select Edit > Paste 

(⌘-V).  All the format settings will be updated to match the graph they were copied from.   


Transfer Settings To All Graphs: Click gear menu on the top right corner of either the Style or 

Canvas settings.  For Style settings, you can chose to ‘Set same style’ or ‘Set same font’ for 
every graph.  For the Canvas settings, you can chose to ‘Set same canvas’ or ‘Set same size’ 
for every graph. Changes will propose to all graphs in your file.


Transfer Commands Between Graphs: In the same way that you copy and paste the 

settings, you can also copy and paste one or more commands between graphs.  The 
difference is that when you paste the commands, new object(s) will be added below the 
settings or any existing commands.  In the target graph, you can select a command in the list 
before you paste to add the new command(s) below the selected command.
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Lesson 4 – Adding Graphs 
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New DataGraph files have one graph.  Click 
the ‘+’ symbol to the right of the graph to add 
more graphs.  Each graph will have a 
thumbnail across the top of the interface.  
Click the thumbnails to toggle between 
graphs.

The current graph will have an outline around 
the thumbnail.

Move any settings or commands between graphs. To select, single click on the object icon 
OR click and drag to select multiple.  Select Edit > Copy.  Next, single click the thumbnail of 
a different graph.  Select Edit > Paste to apply.

When you copy and paste settings, the settings in the destination graph are replaced.  When 
you copy and paste commands, the command objects are added to the existing list of 
commands.



Exporting Images 
A quick way to move an image from DataGraph to another program is to use 'Copy and Paste.' 
First, control-click on the graph window to reveal a context menu. At the bottom of the menu, 
select Copy > Copy Figure. If you need more control, select copy a PDF or bitmap.


Now you can go into other programs and Paste (⌘-V). If you choose Copy Figure, DataGraph 
will paste the best quality graphic, either a vector graphic or bitmap image. If the program 
accepts a vector graphic, the program will paste a pdf; otherwise, it will paste in a bitmap. 


To export the graph to a file, select File > Export Graphic (Shift-⌘-E). Here you can edit the 
file name, destination, and format. Locate the format menu near the bottom left corner. Click 
the menu to choose the file type you want to export. The top half includes vector graphics 
formats (PDF, EPS, SVG), and the bottom half provides bitmap formats (PNG, TIF, JPG). 


If you choose a bitmap format, you can also change the resolution of the image. A resolution of 
72 dpi is standard resolution, while 144 dpi is retina resolution. Unlike a vector image, a bitmap 
image will show pixels when you zoom closely into the image. If the quality of the image does 
not look good, you may want to increase the resolution further.


When you export a graph, it will have the name 'Untitled' by default, but you can specify a 
name using the thumbnail. Hover over any thumbnail, and you will see the word 'Untitled' at 
the top. Click 'Untitled' once to add a custom title that stays visible. When you export a graph, 
the custom name is now the suggested name for the file.


You can use the thumbnail of any graph, even when it is not the current graph, to copy or 
export. Hover your cursor over any thumbnail to reveal the gear menu in the bottom right 
corner. Click the gear menu and select Export or Copy Image.  


You can also export multiple graphs at once. First, flag the graphs you want to export by 
hovering over the thumbnail and click the flag symbol (top right corner). Now select File > 

Export Flagged Graphs (Option-Shift-⌘-E). If your graphs do not have unique names, you will 
get an error. Otherwise, choose a destination folder and click Options to change the file type.
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Lesson 5 – Export with Copy and Paste 

Page  of 13 14

A quick way to transfer a graph to another program is to use Copy and Paste.  Control-click 
on a graph and select Copy > Copy Figure. Go to your destination program to paste the 
image.



Getting Help 
Every object in DataGraph has a directly link to a help article that describes all the option for 
that data type, layout setting, or command.  Click the gear menu on the object and click the 
HELP option at the bottom of the menu. When the command is expanded, you can get the 
same link by clicking the ‘?’ in the bottom right corner. 
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